Minimum Hardware Requirements for Javelin 2018r1

  • The specification below details the requirements to run Javelin systems only. Any other applications using the same server will need to be taken into account in addition to the Javelin requirements.
  • This minimum hardware specification does not imply any particular system performance level, for optimum performance we recommend maximizing your hardware configuration.
  • A fully functioning network consisting of a server connected to one or more workstations with all network components being Windows domain networked.

Minimum Server Requirements

Operating System Hardware Network
32 or 64bit

Windows 2003 Server SP1 or higher including RC2
Windows 2008 Server SP1
Windows 2008 SBS Server SP1

Windows 2011 Server SP1
Windows SBS 2011 SP1

Windows 2012 Server
Windows 2016 Server

Internet Explorer 11 or higher
 
At least a Dual Core 2 GHz Processor
Recommended minimum 4Gb RAM 32bit or 64bit processor (16Gb on 64bit OS)
Network Card operating at 1 Gig or higher

Disc Space requirements:
Javelin Installation – 1Gb
Javelin Data – allow 1Gb per year

Server 2016 will only be supported on Javelin 2016r1 or above

 

 

 

Network protocol TCP/IP
CAT 5 Cabling or above

Workstation Requirements

Operating System Hardware
32bit or 64bit
 
Windows XP Professional
SP3 or higher
 
Windows Vista SP1
Windows 7 SP1
Windows 8 SP1
 
Windows 10
At least a 1GHz Processor
Recommended minimum 2Gb RAM
 
Screen Resolution 1024 x 768 (19” Monitor recommended)
 
Network Card operating at 1Gb or higher
 
Note: Windows XP is no longer supported by Microsoft and whilst we will endeavour to attempt to try get javelin working on this platform, we cannot guarantee absolute functionality.

Windows 10 will only be supported on Javelin v16r1 and above.

NOTE: - Only the above Platforms are currently supported. For any queries regarding the this document, operating platforms that have not been detailed, Working environments i.e. Terminal Services, virtualization, etc. or any further technical advice please contact our installations manager Nilesh Gohil on nilesh.gohil@verosoftware.com before the actual implementation procedure.

MS SQL

MS SQL licenses are required for running Javelin.

Javelin is supported to run on MS SQL 2008 R2, 2012 and 2014 server products, including Express, Workgroup, Standard and Enterprise (server + CAL, or processor licenses).

Please ask your IT hardware suppliers regarding MS SQL licenses and configuration for your server.
For MS SQL minimum requirements please check the Microsoft website.

Please Note:
  • Jobshop versions prior to 2010r1 are not supported on Windows 7.
  • Jobshop versions prior to 2010r2 are not supported on client PCs running 64bit windows.
  • Javelin versions prior to 13r2 are not supported on windows 8
  • Javelin versions prior to 16r1 are not supported on windows 10
 
Exchequer accounts links in Jobshop v9.30 onwards are only supported with Exchequer v5.71.317(e) onwards.

Javelin 2015r1 will only be supported on Exchequer vR1.1 2015 or higher.

If using the Exchequer software, it will remain the client’s responsibility to ensure that they have sufficient COMS licenses which can be obtained by your Exchequer supplier.

Internet access is required to the server and workstations to allow full Jobshop/Javelin support.
 
Crystal reports not written by Planit Software are not covered by Planit Software support.
 
Javelin email is only supported using 32bit MAPI client for Microsoft Outlook 2010, 2013 &
2016. Outlook 2016 (365) can only be supported if the users are using a local MAPI client.
Not Just cloud based.
 
Customers wishing to use the Sage COMS link will require sage licenses for each Javelin workstation.

Note: This specification is correct as or 20/07/2017 and if Microsoft or Unipaas/XPA issues any service pack updates then this specification is subject to change.